Cannot filter out nulls for numerical column with limit filter

I am trying to use a limit filter on a numerical column to get the largest 10 results by rank and exclude nulls. I unchecked the “Include Nulls” option, but all the nulls are still there. Please see the attached screenshot. What am I doing wrong?

Hi Kristian - Your expectation is correct. This is a known issue that our team is already aware of.